Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 17, 2026 - 12:00 CET
Scheduled
Due to an infrastructure upgrade, validation of some signatures will be unavailable for up to an hour starting from 12:00 CET on Saturday 17th January 2026. This includes all signatures with MitID (including MitID Erhverv), Swedish BankID and FTN, signatures with Norwegian BankID from May 2024 - September 2025, and signatures with itsme® before February 2024.
Validation is expected to be available through the remainder of the maintenance window lasting until 23:00 CET, although periodic unavailability might occur.
During the period(s) of unavailability, users of https://app.penneo.com/validator will see information about the unavailability.
Validation of Qualified Electronic Signatures using ID Verifier, Norwegian BankID and itsme® QES are not affected and will remain available throughout the entire maintenance window.
Posted Jan 14, 2026 - 10:09 CET
This scheduled maintenance affected: Penneo Validator.