Intermittent Issues with ID Verifyer Signing

Incident Report for Penneo AS

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 12:14 CET

Investigating

We are currently experiencing technical difficulties with our partner ID Verifyer. As a result, the signing of documents using ID Verifyer may be affected, and users might encounter errors or delays during the verification process.
Posted Mar 06, 2026 - 11:06 CET
This incident affected: Identification and Login Service Providers (ID Verifier).