E-mails from Penneo are delayed
Incident Report for Penneo ApS
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 12:04 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 01, 2020 - 10:48 CEST
Identified
E-mails sent from Penneo are currently delayed. A fix has been implemented, we expect the backlog to be cleared within 1 hour.

As a work-around, you can resend the e-mails from Penneo: https://support.penneo.com/hc/en-us/articles/207176703-Resend-request
Posted Jul 01, 2020 - 09:22 CEST
This incident affected: Amazon Web Services (Sending emails).