MitID Unavailable

Incident Report for Penneo AS

Resolved

This incident has been resolved. mitID reported operational again at 12.22.
Penneo registered mitID activity normalizing from around, on our end at 11.35.
Posted Feb 27, 2026 - 12:38 CET

Investigating

It seems to be a general issue for MitID
Posted Feb 27, 2026 - 10:41 CET
This incident affected: Identification and Login Service Providers (MitID, MitID Erhverv).