Penneo main page down
Incident Report for Penneo A/S
Resolved
This incident has been resolved.
Posted May 07, 2020 - 10:10 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 07, 2020 - 09:39 CEST
Investigating
The Penneo main page is currently down. This only affects the website and not the archive, case file creation and signing documents.

If you want to log in to your archive please go to app.penneo.com.
Posted May 07, 2020 - 09:16 CEST
This incident affected: Penneo Website.