Email Delivery Issues for Signers in Penneo Sign

Incident Report for Penneo AS

Resolved

This incident has been resolved, and all emails that failed to be delivered have now been sent.
Posted Feb 26, 2025 - 14:54 CET

Update

There was an Incident with Penneo Sign that resulted in email notifications not being sent between 15:00 February 24th and 10:00 February 25th. This includes email notifications for both needing to sign a document and when all parties have completed the signing of a document.

Penneo will resend all failed notifications to affected users shortly.

Apologies for the inconvenience.
Posted Feb 25, 2025 - 16:46 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2025 - 10:24 CET

Investigating

We are currently experiencing issues with email delivery to signers in Penneo Sign. This may result in delays or non-receipt of signing emails and finalisation emails. Our team is actively investigating the issue.
Posted Feb 25, 2025 - 09:09 CET
This incident affected: Service API (Workflow service API).