Penneo main page down
Incident Report for Penneo ApS
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 21, 2019 - 13:23 CEST
Monitoring
Our page is now up and running again.
Posted 3 months ago. Jun 21, 2019 - 10:10 CEST
Investigating
At the moment the Penneo main page is down. We are investigating the issue and hope to be back up soon.

If you need to log in to the archive you can do that at https://app.penneo.com/login

We apologize for the inconvenience.
Posted 3 months ago. Jun 21, 2019 - 07:57 CEST
This incident affected: Penneo Website.