Delayed case file finalization and signing issues for BankID Norway and Sweden
Incident Report for Penneo ApS
Resolved
This incident has been resolved.
Posted Mar 14, 2020 - 00:44 CET
Monitoring
We have tested and can finalize case files and sign with Norwegian and Swedish BankID, we are still monitoring the situation and will keep you posted if we observe any changes.

The delayed case files are still processing but is progressing, but should all finishing soon.
Posted Mar 13, 2020 - 08:14 CET
Identified
We are finally beginning to see improvements for case file finalization, and have restarted the queue.

We will keep you posted on the progress.
Posted Mar 13, 2020 - 07:43 CET
Update
Our latest update from GlobalSign:

"Right now the datacentre is stabilizing, however due to big queues of service it will take some time to clear the backlogs.
While this is happening some requests might still not be served (503 error) in order to clear the backlogs in a stabilized way.
This error should gradually reduce and ultimately operations should render normal again."

See current status from GlobalSign here: https://www.globalsign.com/en/status
Posted Mar 12, 2020 - 10:22 CET
Investigating
We are sadly again seeing issues when finalizing case files and signing with BankID Norway and Sweden. The problem is still caused by GlobalSign.

We are truly sorry for this and are in direct dialogue with GlobalSign, and will keep you posted on any news.
Posted Mar 12, 2020 - 09:16 CET
This incident affected: Web Application (Archive / Case file management portal), Login Components (BankID - Sweden, BankID - Norway), and Signing Components (BankID - Sweden, BankID - Norway).