itsme® P1 Incident - all services down

Incident Report for Penneo AS

Resolved

Our partner informed us about an incident with ITSME:
Resolved: Jun 04, 2026 - 16:40 CEST
Monitoring: Jun 04, 2026 - 16:32 CEST
Investigating: Jun 04, 2026 - 16:26 CEST
Posted Jun 04, 2026 - 16:00 CEST