Penneo email certificate is currently misconfigured.

Incident Report for Penneo AS

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 18:21 CEST

Investigating

We are currently investigating this issue and are working on implementing af fix for our email certificate.
Posted Apr 10, 2026 - 10:22 CEST
This incident affected: Penneo Sign Casefile and Document Management (Email notifications).