Penneo.com is unstable
Incident Report for Penneo ApS
Resolved
This incident has been resolved.
Posted May 07, 2020 - 21:19 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 07, 2020 - 16:35 CEST
Identified
We are seeing a high load of traffic to penneo.com, which is causing instability. We are looking into this.

If you are looking for your archive, you can go to https://app.penneo.com which is not affected by this.
Posted May 07, 2020 - 14:54 CEST
This incident affected: Penneo Website.