Signing with ITSME unavailable

Incident Report for Penneo AS

Resolved

Our partner informed us about an incident with ITSME:
- Investigating: Apr 20, 2026 - 09:31 CEST
- Monitoring: Apr 20, 2026 - 09:52 CEST
-Resolved: Apr 20, 2026 - 09:59 CEST
Posted Apr 20, 2026 - 09:30 CEST