SIGN: Users may experience issues with the case file finalisation process.

Incident Report for Penneo AS

Resolved

This incident has been resolved.
Posted Dec 20, 2024 - 15:27 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 20, 2024 - 14:25 CET

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 20, 2024 - 12:39 CET

Investigating

Users may experience issues with the case file finalisation process in Penneo Sign, resulting in the receipt of multiple finalisation emails.

We are currently investigating this issue.
Posted Dec 19, 2024 - 14:46 CET
This incident affected: Web Application (Archive / Case file management portal).