Completed
The scheduled maintenance has been completed.
Posted May 09, 2026 - 22:00 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 09, 2026 - 20:00 CEST
Scheduled
The system will be offline during the maintenance window.
Posted May 08, 2026 - 12:39 CEST
This scheduled maintenance affected: Penneo KYC (API, Client facing web interface for information collection, Customer dashboard and client management), Identification and Login Service Providers (.beID - Belgium, BankID - Norway, BankID - Sweden, Finnish Trust Network, ID Verifier, itsme®, MitID, MitID Erhverv, Classic Credentials, Microsoft Login, Google Login), Penneo Qualified Trust Services (Qualified Electronic Signature, Qualified Electronic Seal, Qualified Electronic Time Stamp), Penneo Sign Casefile and Document Management (Desktop Application, Casefile and document management, Web forms, Email notifications, API and integration services), Penneo Sign Signature Services (Signers’ interface, Penneo QES, Penneo AdES, Penneo SES, itsme® QES, Casefile finalisation), and Penneo Collect, Penneo Validator.