Some users may experience issues uploading documents and sending out casefiles.
Incident Report for Penneo A/S
Resolved
This incident has been resolved.
Posted Jan 04, 2024 - 09:09 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 03, 2024 - 18:05 CET
Investigating
Some users may experience issues when uploading documents and sending out casefiles in Penneo SIGN.
Posted Jan 03, 2024 - 17:05 CET
This incident affected: Web Application (Archive / Case file management portal).