MitID Ervherv is currently unavailable for signing documents and logging in to Penneo SIGN.

Incident Report for Penneo AS

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 13:52 CEST

Identified

Users may experience issues signing documents with MitID Erhverv or logging into Penneo Sign using MitID Erhverv.

This issue has been reported on their website. See the link below for further updates:

https://digitaliser.dk/nemlog-in
Posted Apr 03, 2025 - 12:09 CEST
This incident affected: Signing Components (MitID - Denmark) and Login Components (MitID - Denmark).