Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 17, 2026 - 12:00 CET
Scheduled
Due to an infrastructure upgrade, signing with MitID (including MitID Erhverv), Swedish BankID and FTN will be unavailable for up to an hour starting from 12:00 CET on Saturday 17th January 2026.
Signing is expected to be available through the remainder of the maintenance window lasting until 23:00 CET, although periodic unavailability might occur.
During the period(s) of unavailability, signers will see information about the upgrade and they will be unable to select the impacted signing methods.
Signing with Qualified Electronic Signatures using ID Verifier, Norwegian BankID and itsme® QES are not affected and will remain available throughout the entire maintenance window.
Posted Jan 14, 2026 - 10:08 CET
This scheduled maintenance affected: Penneo Sign Signature Services (Penneo AdES).