Penneo main page
Incident Report for Penneo ApS
Resolved
This incident has been resolved.
Posted 21 days ago. Sep 27, 2019 - 14:52 CEST
Update
The problem have been fixed for most users.
Users behind a VPN might still experience issues. We are looking in to it now.
Posted 21 days ago. Sep 27, 2019 - 14:38 CEST
Identified
We have identified the problem and expect to be up and running again in 5-10 minutes
Posted 21 days ago. Sep 27, 2019 - 14:17 CEST
Investigating
We are looking in to an issue with Penneos main page. Some users get a message of an unsafe page and others are being redirected to our sandbox environment.

If you need to log in to the archive please go to app.penneo.com.
Posted 21 days ago. Sep 27, 2019 - 14:13 CEST
This incident affected: Penneo Website.