Penneo.com website is currently down.
Incident Report for Penneo A/S
Resolved
This incident has been resolved.
Posted Jul 30, 2024 - 11:14 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2024 - 10:15 CEST
Identified
The website https://penneo.com/ is currently down due to maintenance.

You can use the following links to log in to Penneo SIGN and Penneo KYC:

Penneo SIGN: https://app.penneo.com/login

Penneo KYC: https://cla.penneo.com/

Contact Penneo Support team: https://penneo.my.site.com/support/s/contactsupport?language=en_US
Posted Jul 30, 2024 - 09:49 CEST
Investigating
The website https://penneo.com/ is currently down due to maintenance.
Posted Jul 30, 2024 - 09:40 CEST
This incident affected: Penneo Website.