Itsme down

Incident Report for Penneo AS

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 15:28 CEST

Monitoring

A fix have been implemented and we are monitoring the situation.
Posted Aug 26, 2025 - 13:40 CEST

Investigating

Its is not possible to sign or login with Itsme In Penneo at the moment.
Posted Aug 26, 2025 - 12:47 CEST
This incident affected: Login Components (ItsMe - Belgium) and Signing Components (ItsMe - Belgium).