Support Requests - please use hello@penneo.com

Incident Report for Penneo AS

Resolved

Creating support requests through the Help Center is back to full functionality
Posted May 17, 2023 - 10:00 CEST

Update

Creating Support Requests is unavailable and we are working on fixing the issue. Please use hello@penneo.com if you need to contact Penneo Support at this time.
Posted May 16, 2023 - 17:32 CEST

Update

We are continuing to investigate this issue.
Posted May 16, 2023 - 17:32 CEST

Update

Creating Support Requests is unavailable and we are working on fixing the issue. Please use hello@penneo.com if you need to contact Penneo Support at this time.
Posted May 16, 2023 - 17:31 CEST

Update

We are continuing to investigate this issue.
Posted May 16, 2023 - 17:30 CEST

Investigating

Creating Support Requests is unavailable and we are working on fixing the issue. Please use hello@penneo.com if you need to contact Penneo Support at this time.
Posted May 16, 2023 - 17:30 CEST
This incident affected: Web Application (Archive / Case file management portal).