Resolved
Resolved - This incident has been resolved. Between 11:29 AM and 11:48 AM CET, the Penneo platform was unavailable. We have monitored the recovery over the last 20 minutes and confirmed all systems are stable. We apologize for the interruption.
Posted Mar 26, 2026 - 12:11 CET
Update
We are continuing to monitor for any further issues.
Posted Mar 26, 2026 - 12:10 CET
Monitoring
A fix has been implemented at 11:48 AM CET and we are monitoring the results.
Posted Mar 26, 2026 - 11:56 CET
Investigating
Penneo Platform Offline since 11:29 AM CET. We are investigating the issue.
Posted Mar 26, 2026 - 11:42 CET
This incident affected: Identification and Login Service Providers (.beID - Belgium, BankID - Norway, BankID - Sweden, Finnish Trust Network, ID Verifier, itsme®, MitID, MitID Erhverv, Classic Credentials, Microsoft Login, Google Login), Penneo Qualified Trust Services (Qualified Electronic Signature, Qualified Electronic Seal, Qualified Electronic Time Stamp), Penneo Sign Casefile and Document Management (Desktop Application, Casefile and document management, Web forms, Email notifications, API and integration services), Penneo Sign Signature Services (Signers’ interface, Penneo QES, Penneo AdES, Penneo SES, itsme® QES, Casefile finalisation), and Penneo Collect, Penneo Validator, Penneo Sandbox.