Issue Impacting some Belgian Customers

Incident Report for Penneo AS

Resolved

This Incident has been resolved. Penneo will reach out to affected customers
Posted Feb 04, 2025 - 12:35 CET

Monitoring

Issue found affecting some Belgium customers using a certain signing flow. Penneo will reach out to impacted customers.
Posted Feb 03, 2025 - 12:40 CET
This incident affected: Web Application (Archive / Case file management portal).