Our MitID provider reported that MitID is unavailable

Incident Report for Penneo AS

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 13:57 CEST

Investigating

Posted Mar 31, 2026 - 09:28 CEST
This incident affected: Identification and Login Service Providers (MitID, MitID Erhverv).