Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 27, 2025 - 10:03 CET
Scheduled
Product will be offline and signers will be unable to sign documents in the maintenance period.
Posted Nov 26, 2025 - 12:12 CET
This scheduled maintenance affects: Penneo KYC (API, Client facing web interface for information collection, Customer dashboard and client management), Identification and Login Service Providers (.beID - Belgium, BankID - Norway, BankID - Sweden, Finnish Trust Network, ID Verifier, itsme®, MitID, MitID Erhverv, Classic Credentials, Microsoft Login, Google Login), Penneo Qualified Trust Services (Qualified Electronic Signature, Qualified Electronic Seal, Qualified Electronic Time Stamp), Penneo Sign Casefile and Document Management (Desktop Application, Casefile and document management, Web forms, Email notifications, API and integration services), Penneo Sign Signature Services (Signers’ interface, Penneo QES, Penneo AdES, Penneo SES, itsme® QES, Casefile finalisation), and Penneo Support, Penneo Validator, Penneo Sandbox.