Casefiles not finalising

Incident Report for Penneo AS

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 13:35 CEST

Monitoring

A fix have been implemented. We will keep monitoring to make sure everything is working.
Posted Oct 21, 2025 - 11:59 CEST

Identified

We are currently experiencing issues finalising some casefiles. We are currently working on it and will update as soon as it is fixed.
Posted Oct 21, 2025 - 11:05 CEST
This incident affected: Penneo Sign Signature Services (Casefile finalisation).