Penneo unavailable
Incident Report for Penneo ApS
Resolved
This incident has been resolved.
Posted 2 months ago. May 11, 2019 - 00:17 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. May 10, 2019 - 16:39 CEST
Investigating
We are looking into a issue at the moment. It is not possible to access the archive or the signing pages.

Updates will be posted here as soon as we know more.
Posted 2 months ago. May 10, 2019 - 15:10 CEST
This incident affected: Web Application (Archive / Case file management portal, Forms Portal, KYC validation).