Case files not being finalized
Incident Report for Penneo ApS
Resolved
This incident has been resolved.
Posted about 1 month ago. Apr 17, 2019 - 23:59 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Apr 17, 2019 - 20:36 CEST
Investigating
We are currently investigating a issue regarding finalization of case files.

As as we know more we will update you.
Posted about 1 month ago. Apr 17, 2019 - 17:31 CEST