Delayed finalization for touch signatures
Incident Report for Penneo A/S
Resolved
This incident has been resolved.
Posted Jul 20, 2020 - 13:57 CEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 20, 2020 - 12:32 CEST
Identified
We are experiencing a minor delay in the finalization of case files signed using Touch Signature. This affects the case files signed with Touch Signature.

We are working on a fix that will resolve this issue and finalize the affected case files.

ETA 2 hours.
Posted Jul 20, 2020 - 11:52 CEST
This incident affected: Signing Components (Touch Signatures).