MitID Erhverv is currently experiencing downtime
Incident Report for Penneo A/S
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 15:23 CEST
Identified
Our MitID provider is currently experiencing downtime and this affects the ability to login and sign documents with Penneo SIGN.

We are monitoring the situation and you will be able to check the current service level on their statuspage:

https://broker.signaturgruppen.dk/driftsstatus
Posted Apr 09, 2024 - 10:40 CEST
This incident affected: Signing Components (MitID - Denmark) and Login Components (MitID - Denmark).